+1
Completed

Don't show the wand icon all the time

Samuel Jack 7 years ago updated by Omer Raviv (CTO) 6 years ago 4

I find it very distracting seeing the wand icon permanently next to the highlighted line of code

Answer

Answer
Thanks again for your feedback, Samuel. We've taken it very seriously. The new version of OzCode moved the QuickActions over to the margin so that it won't obstruct your view of the code. Also, the QuickActions only show-up at debug time, so they won't disturb you while you edit code. If you want, you can still summon the Quick Actions while writing code by hitting Alt+Shift+D.
Planned - Long term

Hi, thank you for your feedback! We'll make the Quick Actions icon much less intrusive in one of the next releases. In the mean time, if it bothers you, you can disable it from the Options dialog.

Planned - Long term

Hi, thank you for your feedback! We'll make the Quick Actions icon much less intrusive soon. In the mean time, if it bothers you, you can disable it from the Options dialog.

Completed

This was fixed in version 0.9.3321.7327. The wand icon now no longer appear while the caret is moving, and appears black-and-white and semi transparent, so that it won't be too distracting. Please let us know if you still find yourself distracted by it after this change.

Answer
Thanks again for your feedback, Samuel. We've taken it very seriously. The new version of OzCode moved the QuickActions over to the margin so that it won't obstruct your view of the code. Also, the QuickActions only show-up at debug time, so they won't disturb you while you edit code. If you want, you can still summon the Quick Actions while writing code by hitting Alt+Shift+D.