0
Completed

Variable values are not editable while debugging

Daniel Schroeder 8 years ago updated by Guilherme Morais F. 5 years ago 11
When not using BugAid in Visual Studio, you are able to hover over a variable to see its value when debugging, and optionally can edit the variable's value.  When BugAid is enabled and you get the BugAid mouse-hover window, the variable value is read-only and cannot be changed.  It would be great if you could restore this VS functionality so that variable values can be edited from this tooltip window.

Answer

Answer
Completed
Existing feature
Hi Daniel,

Actually, editing values from BugAid's on-hover data-tip should work fine. The only difference from the default Visual Studio experience is that you have to double-click on the variable's value to start editing (rather than a single click). We made it a double-click instead of a single click because we were often annoyed when we accidentally caused Visual Studio to start editing even when it's not what we intended.
Bah, I can't believe that I missed that.  Thanks, double clicking works as expected :)  Sorry to waste your time.
No problem at all, we're happy to answer any question you have. :)
Answer
Completed
Existing feature

Well, this is not working for me. I can doubleclick and edit, but the variable doesn't change. In the normal watch window it works ok.

Thanks for reporting this, Robert! Did the Watch window work for you on the same exact variable? There are some variables that the Watch window will let you edit and some that it won't. If it is indeed the same exact variable, could you please give us more information on what you were trying to change (was it an item in a collection and if so what sort of collection, etc?)

Yes, watch worked for exactly the same variable. I've played a bit more and I think I found the problem - it happens if I try to edit the field that I got to by searching - example here https://dl.dropboxusercontent.com/u/153770/ozCodeCantChangeField.png 


also, after I try to edit it (after I press enter on the new value) I get this kind of screen https://dl.dropboxusercontent.com/u/153770/ozCodeCantChangeField2.png. 


If I go to the same fields by navigating the hierarchy they edit ok. 

Hi again Robert, thanks a lot for the report! I confirmed this problem and added it to our bug tracker. 

Hi, guys!
  I tried to use this feature today and get the same issue, even when double clicked, is not working. You double click on the text, he goes to a blank textbox but it´s not possible to enter any text. 

-----
OzCode version: 1.0.4423.3818
Visual Studio version: 10.0 (10.0.40219.1 built by: SP1Rel)
Visual Studio edition: Professional
Visual Studio service pack: 1
Windows version: Microsoft Windows NT 6.1.7601 Service Pack 1
Is 64bit: True
Locale ID: 1033
Installed addins:
Addin name: dbForge SQL Complete 4.0.120. Loaded: True
Addin name: TestDriven.Net 3.3 Beta 2 Personal. Loaded: True
Addin name: GhostDoc. Loaded: True


JetBrains ReSharper 8.2 Full Edition
Build 8.2.0.2160 on 2014-03-20T22:53:08
Plugins: 4
#1. “Agent Ralph” v1.3.4.0 by “Josh Buedel”
#2. “Clean Code” v4.0.0.30301 by “Hadi Hariri and Contributors”
#3. “ReSharper PowerToys: Cyclomatic Complexity” v3.0.0.0 by JetBrains
#4. “NuGet support for ReSharper” v1.3.0.35071 by JetBrains
Visual Studio 10.0.40219.1.


Copyright © 2003–2014 JetBrains s.r.o. All rights reserved.


Hi, Guilherme! Thank you very much for reporting this. Would it be possible for your to send us a screenshot of the code and the DataTip when this happened, to support@oz-code.com? That would really help us track this issue down.
Hi, Omer.
    I just sent you one e-mail but I will also write here to keep the record. I find you, when you attach a process then you can´t edit the values using the interfaces.

I Hope this will help. Thanks