+1
Completed

Let QuickWatch window remember its size

Uwe Honekamp 8 years ago updated by Tony Henrich 5 years ago 11
Every time I open the QuickWatch window it opens at a default size.

Even if I resize it manually, every new instance will always come up with the default size.

Unless one of my other VS extensions tricks me, the QuickWatch window that comes with VS makes a point of remembering the size it had at the last instance. It will always come up with the size it had when it was closed the last time it ran rather than the default size.

I'd like BugAid's QuickWatch window to behave similarly: always open with the size it had last time it closed.

Answer

Answer
Completed
Fixed in BugAid's latest version. 
Started
It is an important and valuable fix and it should be easy to do. I expect it to be in the next version.
Thanks for the fast response. For the sake of completeness (but surely you figured that out already), I forgot to mention the position of the window. I guess it would look awkward if the window came up at arbitrary positions on the screen.
This doesn't work in Beta v2 in VS 2013. Every time I use QuickWatch, I have to expand the QuickWatch window.
Hi Abdu, can you please check if the issue you experienced is the same as the one show in Tony's video below?
Fixed 3 years ago? As of now (2.0.0.922), every time I launch QuickWatch, I have to resize it from its default size. Please fix. I am using VS 2015.
Hello Tony, we've been trying to reproduce situations wherein the QuickWatch window does not remember its size. So far the only situation where we see this happening is when you extend the window to take the entire screen's width or height. Is that the situation in your case? Can you please send us a screenshot or even better, a short video? Thank you for your patience.
The video shows me opening QuickWatch and subsequently opening it up again and expanding it


Hi Tony, as it turns out, OzCode does not remember the QuickWatch size and position when the window is slightly out of the screen, as is shown in your video. We will fix this by adding some 'tolerance buffer' around the screen in which this is still allowed.

This fix will be deployed in a few weeks. For now, you can simply move the QuickWatch window downwards a little bit so it is fully contained in the current screen to avoid the problem. Thanks again for the report, and for taking the time to record this video, we really appreciate it!
Well.. why is the window showing up a little off the screen in the first place? It should be showing a few pixels below the top edge. Also I manually move the window down and then enlarge it which means at the time I hit the Close button, the window IS at the proper position and size. This should be evident in the video. When the window closes that's when OzCode should be saving the position and size. Right?

Anyway, the reason I enlarge the window is to display more data so why not just open the window at a % size of the screen like 90%. It's a modal window so there's nothing else I can do other than interacting with the window so might as well open it quite big. Some of us use large monitors so it makes sense to open that modal window large too. It's always better to have it large than small anyway. You can make it a setting for people who prefer this scenario.

Thanks for considering this issue.


Actually the window is inside VS's Window.. The screen capture size was part of VS's window so it looked like it was partly off the screen but it's not. So there's no out of screen issue.