+1
Completed

Quickwatch is sluggish/slow sometimes when expanding

Tony Henrich 7 years ago updated by Omer Raviv (CTO) 6 years ago 3

There are sometimes when I click the plus sign to expand the top node and it takes seconds to open. It makes me think I didn't click properly so I click again and what happens is that it expands then collapses because Windows registered both clicks. I am guessing this issue is related to the amount of data in the variable? I am thinking this functionality needs some more performance optimization.

Answer

Answer
Completed
The new version of OzCode that we just released today includes very substantial performance improvements in the DataTip. Specifically, collapsing/decollapsing of nodes is now a lot smoother even when there is a large amount of data on display.

Thank you for reporting this! We haven't seen this occur before.  The next time this happens to you, if you could profile it with any Performance Profiler (such as dotTrace, ANTS, etc), and send us the result (to support@oz-code.com), or send us a code sample that reproduces the issue, that would really help us to figure out what went wrong.

I think I had a similar issue when I expanded the top level element it looked like it had expanded but the window didn't stretch to show the child items. I clicked out to make the window disappear then tried again and it worked. I am new to this but so far I have not been able to recreate the issue.

Answer
Completed
The new version of OzCode that we just released today includes very substantial performance improvements in the DataTip. Specifically, collapsing/decollapsing of nodes is now a lot smoother even when there is a large amount of data on display.